14:47:02 <lincolnthree> #startmeeting
14:47:02 <jbott> Meeting started Wed Jul 16 14:47:02 2014 UTC. The chair is lincolnthree. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:47:02 <jbott> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:47:03 <jbossbot> Title: 3MeetBot - Debian Wiki
14:47:12 <lincolnthree> #chair gastaldi
14:47:12 <jbott> Current chairs: gastaldi lincolnthree
14:47:20 <lincolnthree> #addtopic Agenda
14:47:22 <lincolnthree> #nexttopic
14:47:22 <jbott> #topic Agenda
14:47:36 <gastaldi> #addtopic Forge 2.7.1.Final release
14:47:56 <gastaldi> agoncal, got something to discuss?
14:48:29 <lincolnthree> #addtopic JBT status
14:48:35 <agoncal> Hum.... not really
14:48:50 <emmanuel> agoncal: you're so chatty usually, are you sick?
14:49:11 <agoncal> No, I'm struggling with JBoss Console APIs ;o)
14:49:43 <jbossbot> git pull req opened [12jbosstools-forge] (7open) 6gastaldi JBIDE-17241: Maven settings are now set via MavenPlugin's listener mechanism11 https://github.com/jbosstools/jbosstools-forge/pull/82
14:49:44 <jbossbot> jira [3JBIDE-17241] Forge should use the m2e settings.xml during Maven artifact resolution [10Closed (Done) Feature Request,7 Major,6 George Gastaldi] https://issues.jboss.org/browse/JBIDE-17241
14:49:56 <agoncal> Last week I've created a JIRA to list all the new possible commands
14:50:05 <agoncal> FORGE-1926
14:50:06 <jbossbot> jira [3FORGE-1926] Adding more commands to Forge and improve existing ones [10Open (Unresolved) Task,7 Major,6 Unassigned] https://issues.jboss.org/browse/FORGE-1926
14:50:22 <nchal> agoncal: un petit aparté, je profite de ce moment pour te remercier de ta conférence Devoxx sur la forge. Elle m'a bien aidé pour commencer :D
14:51:06 <agoncal> I feel, as a Forge user, that I miss a few commands... that's why I suggested to add at least one more new command to each release ;o)
14:51:09 <lincolnthree> agoncal: *warm hug*
14:52:12 <gastaldi> agoncal, we have the "rest-new-cross-origin-resource-sharing-filter" command :)
14:52:58 <agoncal> gastaldi Gosh, what does this do ?
14:53:04 <gastaldi> Creates a CORS filter
14:53:28 <gastaldi> like this: https://github.com/AdamBien/cors/blob/master/src/main/java/com/airhacks/cors/CorsResponseFilter.java
14:53:31 <lincolnthree> #nexttopic
14:53:31 <jbott> #topic Forge 2.7.1.Final release
14:54:11 <gastaldi> given that all tests are passing, I think we're good to release 2.7.1.Final unless proven otherwise
14:55:18 <agoncal> gastaldi And you will announce it on the new website.... and bring the "News" menu back to the top bar menu ? ;o)
14:55:54 <gastaldi> hum, I don't remember the outcome of this discussion
14:56:08 <gastaldi> I think we'll add a news section in the home page
14:56:18 <gastaldi> not sure though
14:56:48 <lincolnthree> agoncal: yes we are bringing news back to the menu
14:56:49 <agoncal> gastaldi "News" should be in the top menu instead of "Home" (clicking in the Forge image brings back home already)
14:56:53 <lincolnthree> agoncal: probably under resources I think is what we decided
14:57:00 <lincolnthree> agoncal: or that was another option
14:57:12 <gastaldi> ah right, instead of Home
14:57:21 <lincolnthree> gastaldi: yeah i think we can go ahead and do that
14:57:25 <gastaldi> cool
14:57:59 <nchal> i agree with agoncal, jboss forge console is very convenient to create a CRUD javaee application but i feel like a lack of personalisation
14:58:36 <jbossbot> git [12website] push 10master7 fb581d2.. 6George Gastaldi News menu is now available
14:58:36 <jbossbot> git [12website] push 10master URL: http://github.com/forge/website/commit/fb581d23a
14:58:38 <gastaldi> done
14:59:13 <gastaldi> updating our website now
15:00:25 <gastaldi> nchal, right, we're open to suggestions
15:01:07 <gastaldi> the website is looking good with this change
15:01:31 <agoncal> gastaldi Brilliant !!
15:02:47 <nchal> gastaldi : I think that I don't know the forge enought to allow me to make suggestion
15:03:06 <gastaldi> ok, any outstanding remaining blocker issues before we release 2.7.1.Final?
15:03:13 <gastaldi> say it now or forever hold your peace :)
15:03:41 <gastaldi> #action Forge 2.7.1.Final will be released today (Jul16th)
15:04:10 <gastaldi> next topic?
15:05:25 <agoncal> gastaldi Any news of the Intellij IDEA plugin BTW ?
15:05:49 <gastaldi> adamw_, would you like to say something?
15:05:58 <gastaldi> agoncal, adamw_ is working hard on it
15:06:29 <adamw_> all components (except Spinner, left that for later) are now implemented
15:06:52 <agoncal> adamw_ Impressive. Can't wait ;o)
15:07:02 <lincolnthree> adamw_: wow! I am looking forward to seeing that :)
15:07:06 <adamw_> I think that only autocompletion, prompt and progress monitor support is missing for full gui support
15:07:45 <gastaldi> w00t
15:08:07 <gastaldi> adamw_, do you need any assistance?
15:08:19 <gastaldi> you're doing a hell of a great job, btw
15:08:31 <adamw_> gastaldi: probably with that furnace stuff
15:08:47 <gastaldi> which furnace stuff?
15:09:15 <adamw_> related to different classloaders in intellij and forge
15:09:34 <gastaldi> hm, I'd like to see this
15:09:51 <adamw_> but I wanted to fix that after fundamental features are done
15:09:54 <gastaldi> sure
15:11:03 <gastaldi> ok, next topic
15:11:06 <gastaldi> #nexttopic
15:11:06 <jbott> #topic JBT status
15:11:43 <gastaldi> looks like the most outstanding issues were fixed in JBT for Beta3
15:12:36 <gastaldi> there is one that was bumped to CR1, due to timeframe: JBIDE-17492
15:12:37 <jbossbot> jira [3JBIDE-17492] Forge2: CLI appears to stall when project has errors [10Open (Unresolved) Bug,7 Critical,6 George Gastaldi] https://issues.jboss.org/browse/JBIDE-17492
15:25:24 <mbriskar> btw, why is having the forge website menu on the right? :-)
15:25:54 <gastaldi> mbriskar, that's part of our current design
15:26:27 <mbriskar> gastaldi: it actually looks (at least for me) like a bug
15:27:10 <lincolnthree> gastaldi: ah yeah :( that issue is tough
15:27:22 <mbriskar> but besides, the page looks working :-) GJ
15:27:41 <gastaldi> mbriskar, you mean it renders different than http://i.imgur.com/e9EpsUz.png?
15:28:10 <mbriskar> gastaldi: it is that way, however I would expect that "news,download,addons,community,resources" to be centered
15:28:37 <gastaldi> since we have a webdesigner changing all of this stuff, we'll not change it atm :)
15:29:03 <mbriskar> gastaldi, ah, the page is not finished right now?
15:29:06 <lincolnthree> mbriskar: yeah not worth spending too much time on it atm
15:29:11 <lincolnthree> mbriskar: not at all :)
15:29:27 <gastaldi> new times are coming :)
15:29:30 <nchal> mbriskar: IMHO, i prefer the menu in the right ;)
15:29:35 <mbriskar> ah, then it is good :-)
15:29:40 <nchal> on*
15:30:19 <mbriskar> nchal: yeah, right the forge is the "right choice" :-) I see the point now! :-)
15:30:29 <gastaldi> haha yes
15:30:51 <gastaldi> Use Forge and Furnace for all your "boilerplate" code
15:31:03 <mbriskar> and whole page will be right-centric :-P
15:31:59 <gastaldi> alrighty
15:32:05 <gastaldi> #nexttopic
15:32:05 <jbott> No next topic. Use #addtopic to add topics.
15:32:12 <gastaldi> anything else?
15:32:15 <mbriskar> ups, I got into meeting, sry
15:32:33 <lincolnthree> ok. looks like this is done anywya :)
15:32:42 <gastaldi> yeah, it's a wrap
15:33:03 <gastaldi> thank you everyone
15:33:06 <gastaldi> #endmeeting